MeisterKühler

GELÖST — Bash – Root Login und Prozesstart

Willkommen in der Mk-Community Foren Software Linux/Unix GELÖST — Bash – Root Login und Prozesstart

Ansicht von 2 Antwort-Themen
  • Autor
    Beiträge
    • #502905
      spokekiller
      Teilnehmer

      Hallo,

      ich steh grade ein wenig auf der Leitung glaube ich.

      Folgende Situation: ich betreibe ein Cubietruck 3 mit Cubian, einem Debian Klon.

      Wenn immer ich mich als Root einlogge, bzw per sudo -i wechsle, bekomme ich Fehler darüber, daß der Prozess devmon (gehört zu udevil) mehrfach gestartet ist. Meine Message Logs sind auch voll davon.

      Durch Purgen des udevil Paketes habe ich das jetzt mal auf die brutale Art abgestellt. Dafür bekomme ich jetzt aber Meldungen wie:
      [code]
      master@drusilla:~$ sudo -i
      -bash: /usr/bin/devmon: No such file or directory
      [/code]
      Überrascht mich jetzt nicht wirklich. Frage jetzt also: wo könnte der Start von udevil bzw devmon noch eingebunden sein? In .bashr, /etc/profile sieht alles normal aus und “defaultig”. Ich kann das auf Wunsch posten.

      Kann mir bitte einer sagen, wo ich da noch suchen kann?

      Danke,
      Spoke

    • #944993
      ulv
      Teilnehmer

      Evtl. nimmst Du die Fehlermeldungen etwas zu wörtlich. :-k
      Hast Du mal nachgesehen ob die Dependencies von devmon alle erfüllt sind?
      Läuft noch ein weiterer automounter?
      Funktioniert das Automounting von USB-Sticks etc. in /media überhaupt?
      Siehe: http://igurublog.wordpress.com/downloads/script-devmon/

      Auf obiger Seite steht etwas von einem ~/.config/autostart Verzeichnis. Gibt es das bei Cubian?

      Ich würde an Deiner Stelle auch mal die Platte mit find / -name “*devmon*” absuchen.

    • #944994
      spokekiller
      Teilnehmer

      ulv, Du bist der Held… ich sag ja ich stand auf der Leitung!Ein find brachte eine devmon.sh unter /etc/profile.d/ zu Gesicht und die rausgeballert hat mir geholfen.[code]root@drusilla:/# find / -name “*devmon*”/etc/profile.d/devmon.sh/etc/init/udevmonitor.conf^Croot@drusilla:/# [/code]Aber zur Vollständigkeit: nein, es läuft kein weiterer automounter. Die Kiste hat auch keinen Desktop konfiguriert und läuft als headless Server. Root hat by default kein .config subdir und soweit ich weiss werden die autostart subdirs nur von den gängigen Desktops wie LXDE, Gnome etc angefahren. Kann auch sein, daß ich mich täusche.Aber im Wesentlichen gings mir nur drum, den (a) Automounter loszuwerden [wo kommen wir da hin wenn da jeder was reinstöpseln würde :D] (b) die resultierende Fehlermeldung nach brutalem apt-get purge’n des udevils wegzubekommen. An /etc/profile.d/ hatte ich nicht mehr gedacht.Gruß nach München,Micha

Ansicht von 2 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.
 
Zur Werkzeugleiste springen