MeisterKühler

[gelöst] Problem mit Sektor 0 – grub läuft nicht

Willkommen in der Mk-Community Foren Software Linux/Unix [gelöst] Problem mit Sektor 0 – grub läuft nicht

Ansicht von 3 Antwort-Themen
  • Autor
    Beiträge
    • #484220
      stimpy
      Teilnehmer

      Hab neue Hardware gekauft und OS neu installiert, in der Reihenfolge:

      1. WinXP
      2. WinVista
      3. kubuntu

      Aber kubuntu ließ sich nicht installieren, weil es die Partitionstabelle der ersten Festplatte nicht erkennt und auch die Acronis Disk Director Boot-CD findet Fehler in Sektor 0, stört sich aber nicht weiter dran. – Auch die Windows-System laufen ohne Probleme, nur der MBR ist verfriemelt.

      Also habe ich gemacht:
      – WinXP-CD rein
      – “Reperaturkonsole” gestartet
      – fixmbr

      Doch keine Änderung, immer noch Fehler in Sektor 0. Und der Vista-BootLoader ist natürlich futsch.

      Also habe ich Platz auf Festplatte 2 geschaffen und kubuntu einfach da installiert mit dem Ergebnis, dass grub “Fehler 17” ausgibt und der Rechner nicht startet. – Könnte das an der 136GB Grenze liegen, obwohl mein BIOS meine Platte richtig erkennt?

      Dann wollte ich den MBR mit der Vista-DVD reparieren, was mir aber nicht gelungen ist weil die Vista-Automatik meint, dass alles in Ordnung ist.

      Deswegen hab ich dann Acronis Disk Director 10 OS Selector installiert, bekomme aber nur WinXP angezeigt.

      Was stimmt mit meiner Festplatte/ Sektor 0 nicht und was kann ich deswegen tun?

    • #700329
      HisN
      Teilnehmer

      Wenn Du Zeit hast:- dir nen Boot-Diskettchen mit fdisk machen- alle Partitionen auf der Platte löschen- mit fdisk /mbr den mbr neu schreibenDann- http://www.forumdeluxx.de/forum/showthread.php?t=249211 nach dieser Methode WinXP und Vista in zwei Primäre Partitionen installieren, Reihenfolge egal.- für Kubuntu in Windows eine Erweiterte Partition und die Logischen Laufwerke (sind ja mindestens zwei für Root und Swap) anlegen- kubuntu installieren komplett mit grubIch denke das Problem ist die Partitioniererei. Du machst das scheinbar mit 10 verschiedenen Programmen. Ich würde das, wenn es geht nur mit einem machen. Entweder Du legst alle Partitionen schon vom Start an mit einem Programm Deiner Wahl an, oder Du machst das von Windows aus. Wenn man das partitionieren von Windows, Tools und Linux mischt könnte so was wie bei Dir entstehen.Nur ein Gedanke, und vielleicht ein Tip. Keine Gewähr das es funktioniert, aber ich denke das es so gehen wird, hat es nämlich schon x-mal bei mir gemacht^^. Ausserdem sparst Du Dir dann das Gehangel durch DREI Bootloader wenn Du mal XP starten möchtest. Nebenbei ist XP nicht vom Vista-Start abhängig, bzw Vista nicht von der XP-Partition (schliesslich liegen da die Vista-Start-Dateien). Dann kommste auch nicht mehr in solche lustigen Schwulitäten mit den Bootloadern wie Du sie jetzt hast. XP und Vista würden dann nämlich einfach noch starten wenn man ihre Partitionen mit Fdisk aktiv setzt. Nix anderes machen nämlich z.b. Grub oder alternative Bootloader.Einen Tip wie es nachträglich bei Dir funktioniert fällt mir leider nicht ein, weil ich keinen Schimmer habe was Du da vergurkt hast 🙂

    • #700515
      stimpy
      Teilnehmer

      Na toll! Alles löschen kann doch jeder! 😉 Aber im Ernst, danke für die ausführliche Antwort HisN! :d:

      – ich hatte alles bevor ich installiert hab mit Acronis partitioniert, das Linux-Part.-Tool brauch ich nur um dem Installationsassisten zu sagen, wo er hin installieren soll – oder wie kommst du auf 10 verschiedene Programme?

      – das mit dem Verstecken ist eine gute Idee, hab ich zu Win98 Zeiten auch immer gemacht, bin aber irgendwie davon abgefallen, frag mich gerade selber warum :-/

      Folgendes hab ich jetzt gemacht:

      – alles mögliche probiert um nicht neu-installieren zu müssen

      – keinen Erfolg gehabt

      – gemacht was HisN geschrieben hat

      – Erfolg gehabt (BTW: warum sollte ich jetzt eigentlich kubuntu auf einer logischen Part. installieren?)

      Ich denke jetzt auch zu wissen woran es lag. – Vista! Woran auch sonst? (Und an meiner Partitionierung, aber für mich ist trotzdem Vista schuld.)
      Ich hatte beim ersten Versuch folgende Partitionen:

      | primäre FAT32 für XP | logische FAT32 | primäre FAT32 für Vista | logische FAT32 | primäre EXT3 | logische FAT16 | logische SWAP |

      Das primär-logische Streifenmuster war offenbar keine gute Idee, aber der Todesstoß kam durch die FAT32 für Vista. Die Vista-Installation hat diese in NTFS umformatiert und dabei primär und logisch durcheinander gebracht. Das heißt Vista war der meinung auf einer logischen Partition installiert zu sein, während Acronis und Linux diese als primär erkannten. – Rien ne va plus!

      Jetzt hab ich:

      | primäre FAT32 für XP | primäre FAT32 für Vista | logische EXT3 für kubuntu | logische FAT32 | logische FAT32 | logische FAT16 | logische SWAP |

      und bisher keine Probleme (teuteuteu).

    • #700520
      HisN
      Teilnehmer

      coool.Und Du solltest das Linux auf ein logisches Laufwerk installieren weil Du maximal 4 Primäre Partitionen auf einer Platte anlegen kannst, Du aber jetzt 7 Partitionen hast, das wäre nicht gegangen :-)Und das mit dem 10 Programmen hat sich so angehört in Deinem erste Post. Als hättest Du mit allem was Du finden kannst an den Partitionen gearbeitet.

Ansicht von 3 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.
 
Zur Werkzeugleiste springen