MeisterKühler

geniale Lüftersteuerung *Pustekuchen*

Willkommen in der Mk-Community Foren Hardware Bastelecke geniale Lüftersteuerung *Pustekuchen*

  • This topic has 15 Antworten, 7 Teilnehmer, and was last updated vor 15 years by Hawk.
Ansicht von 15 Antwort-Themen
  • Autor
    Beiträge
    • #474358
      fniffi
      Teilnehmer

      Hallo,
      habe hier noch ein paar bauteile rimliegen und dachte, ich könnte mir mal eine geniale Lüftersteuerung bauen.
      http://www.fniffi.de/lsklein.jpg

      grosses Bild http://www.fniffi.de/lsgross.jpg

      Funktionbeschreibung ( SOLL):
      Der Lüfter läuft bei eingeschaltetem Computer immer auf 7V.

      1. Taster power ON/OFF wird betätigt und gleichzeitig der Elko aufgeladen und der Lüfter auf Full Speed gebracht. LED rot geht aus, LED grün ist aus und gelb an.

      2. Taster Power ON/OFF wird betätigt, Elko wird aufgeladen und Lüfter bekommt Full Speed. Läuft eininge Sekunden nach und geht dann in einen langsamem Betrieb bei 4,3 V über. LED rot geht an und alle anderen LEDs aus.

      3. über die Mainboard-Lüftersteuerung soll bei Überschreitung der 7 V auch der Lüfter schneller laufen und die blaue LED leuchten. Sobald maximum Warp erreicht ist, soll die gelbe LED leuchten. Die Leuchtstärke der LED variiert zwischen dunkel und sehr hell, so dass diese auch als Spannungsanzeige fungiert.

      Mit dem Poti an +5V VSB kann ich noch die Geschwindigkeit des Lüfters regeln, da am Lüfter der Durchschnitt aller Spannungen und die Summe aller Ströme anliegen soll.
      Doch das funktioniert nicht wie erwartet, die Bauteile sind alle intakt und die Ströme fliessen auch wie gewünscht.
      Aber ich bekomme entweder nur 4 Volt oder 12V am Lüfter und keine Zwischenwerte, klemme ich MB-Controller ab und trenne ich die 5V, funktioniert der Lüfter, wie gewünscht im Dauerbetrieb mit 7V und beim Ausschalten, 10 Sek. lang mit 12V abfallend.
      Da ist also ein Denkfehler drin..

    • #541272
      Fernmelder
      Teilnehmer

      mhmm jo ich glaub da habe ich was gefunden:

      die z-dioden darfst du ne tin reihe schalten…..die polung wäre ja ok, aber mit einer solchen diode musst du einen spannungsteiler aufbauen..

      du brauchst einen vorwiderstand und danach wird die diode in sperrrichtung betrieben…allerdings muss die anode auf den vorwiederstand und die kathode direkt auf masse. sonst geht es nit…
      z-dioden sind nicht dafür gedacht spannung zu verbrennen wie zb ein festspannungsregler….diese aufgabe übernimmt immer der vorwiderstand und muss demnach auch berechnet werden…eine z-diode ist nur zur spannungsstabilisierung da.

      also den vorwiderstand berechenen also bei 12V müssen an ihm 7.7V abfallen bei einen strom von XXmA also berechnest den so und dann muss der verbruacher egal ob LED oder Lüfter immer parallel zur diode geschaltet werden!!! niemals in reihe damit….

      http://www.elektronik-kompendium.de/sites/bau/schalt/02012111.gif

      oben siehst du das schema….

      wenn sonst noch fragen sind einfach nochmal posten 🙂

      mfg

    • #541324
      fniffi
      Teilnehmer

      hallo,
      danke für die Antwort, aber die zenrdiode ist hier nicht der Fehler, den ich habe das schon in einem extra Versuchsaufbau getestet. Unten an der gelben Leuchtdiode habe ich auch eine Zenerdiode 4,3 V mit einer Leuchtdiode, die ähnlich wie eine Zenerdiode funktioniert, weil die konstant 2 V Spannungsabfall hat, auch bei z.B. 43 Grad.
      d.h. alle drei Schaltungen funktionieren im Versuchsaufbau einzeln, nur wenn ich die drei Varianten in einer ODER-Funktion zusammenschalte geht es nicht wie gewünscht.

      Die ZPD 10 hat Ptot von 500mW, d.h. ich kann bei 4,3V Spannungsabfall (I=P:U) 116 mA durchjagen. Da der Lüfter bei 7 V aber nur max. 80mA zieht, kann das nicht der Fehler sein. Habe ich auch gemessen, die Ströme stehen in blau da.

      aber da fliessen noch 10 mA über die Schaltung mit der gelben Zenerdiode und in den Elko und 10 mA über die grüne Diode, die hier den Spannungsabfall an der Zenerdiode anzeigt. Die Spannung vor der Diode ist mit 7,7 V auch korrekt.

      mein Gedanke war, wenn eine höhere Spannung anliegt, dann fliesst in den Schaltungen mit geringerer Spannung kein Strom mehr, weil die Dioden als Schalter arbeiten.
      Das passiert jedoch nicht.. 🙄

      *mom*, jetzt sehe ich gerade, dass ich gar keine 12V messen dürfte, sondern max. 11,3 V 😆 ich habe einen kurzen 🙁

      edit: PS: es geht hier nur darum Bauteilereste sinnvoll zu verwerten, einen L200 und LM335 habe ich auch noch, anstatt sie wegzuwerfen oder extra LM317 zu bestellen.

    • #541326
      fniffi
      Teilnehmer

      dann mal her mit dem Schaltplan *ggg*

    • #541325
      Fernmelder
      Teilnehmer

      naja dann bin ich mal gespannt was aus dem teile verwerten wird *lol*

      sowas ähnliches hatte ich damals auch mal gebaut allerding mit spannungsregler….

      mfg

    • #541407
      MikeP
      Teilnehmer

      funktioniert die obige schaltung denn nu so ?

      (mir ist es ein rätsel wie die schaltung auf 4,3V kommt(kommen soll), wenn dein lüfter doch immer über der Z-Diode an 12V hängt (ergo 7,3V bekommt))

    • #541448
      fniffi
      Teilnehmer

      wenn der PC im standby-Betrieb ist, gehen die 12V aus und der Lüfter wird über die 5V VSB versorgt, da muss aber das ATX-Netzteil genügend Strom für 5V VSB liefern können; meins kann da bis 2 A liefern…
      ist der PC an, regelt der Lüfter natürlich zwischen 7,3 und 11,3 Volt…
      die blaue LED leuchtet daher natürlich nur wenn der FET sperrt, was vom RS abhängt (ist da falsch gezeichnet ).

      Regelt die MB-Steuerung unter 7,3 V, soll der Lüfter über die 12V versorgt werden.

    • #541490
      MikeP
      Teilnehmer

      achso
      sorry hatte den standby net mit “kalkuliert”

    • #541871
      Bugbear
      Teilnehmer

      ich habe einen kurzen

      Da kannst du ja nix für 😆
      Angeblich sollen ja 6cm reichen um eine Frau glücklich zu machen. 😆

    • #541915
      Hawk
      Teilnehmer

      Sprecht ihr aus Erfahrung? 😆
      Sorry, der musste jetzt sein 😉

    • #541914
      MikeP
      Teilnehmer

      ich denke 5cm ??? *sfg*

    • #541920
      Bugbear
      Teilnehmer

      Sprecht ihr aus Erfahrung?

      Jaaaa, leider. Mein Weibchen sagt mir das immer. 😥
      Sie sagt: “wenn du doch nur 6 cm hättest, das würd schon reichen”
      Daher weiß ich das. x/

      😆 😆 😆 😆 😆 😆 😆 😆 😆 😆 😆 😆 😆

    • #541921
      Don_Venuto
      Teilnehmer

      Oh dann hab ich ja viel zu viel des guten ^^
      Wer bezahlt mir die OP? 😆

    • #541917
      breaker
      Keymaster

      Laut Matador (oder so ähnlich) sollten es im Schnitt 14 cm sein 😛

    • #541945
      fniffi
      Teilnehmer

      Bugbear said:

      ich habe einen kurzen

      Da kannst du ja nix für 😆
      Angeblich sollen ja 6cm reichen um eine Frau glücklich zu machen. 😆

      aber je kürzer desto mehr sprühen die Funken und je höher die Spannung desto mehr kribbelt es, besonders wenn noch der Finger dazwischen klemmt OO

    • #541969
      Hawk
      Teilnehmer

      Deswegen immer eine Hand auf den Rücken und nicht beide Steckerkontakte gleichzeitig berühren OO
      Jetzt geht´s aber los hier 😆

Ansicht von 15 Antwort-Themen
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.
 
Zur Werkzeugleiste springen